[WinError 127] ("The specified procedure could not be found.")

Kai Wiechen kwiechen1 at gmail.com
Wed Apr 13 03:35:58 EDT 2016

Hi Benjamin,

I have already tried dependency walker and there are a lot of missing
api-ms-win*.dll errors. And I have tried to build the python bindings by
myself, but this seems to have a visual c++ v10 dependency. Is it possible
to switch to visual studio 2013 or 2015?

Best regards,


2016-04-13 5:23 GMT+02:00 Benjamin Gilbert via openslide-users <
openslide-users at lists.andrew.cmu.edu>:

> On Mon, Apr 11, 2016 at 08:31:43PM +0200, kwiechen via openslide-users
> wrote:
> > running openslide-show-properties works when calling in the bin directory
> > but not when I move the binary to another location.
> >
> > I am using Windows 10 Pro 64 bit.
> Hi Kai,
> It's expected that the .exe won't work when separated from its DLLs.  It's
> interesting that it works at all, though: there's a missing symbol
> somewhere
> in the dependency chain, but evidently one that's only accessed when
> OpenSlide is loaded into Python?  I can't track this down right now, but
> I'll try to take a look when I get a chance.  Meanwhile, if you get
> anywhere
> with it, let us know.  Checking for Dependency Walker errors on
> libopenslide-0.dll might be a good place to start.
> --Benjamin Gilbert
> _______________________________________________
> openslide-users mailing list
> openslide-users at lists.andrew.cmu.edu
> https://lists.andrew.cmu.edu/mailman/listinfo/openslide-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.andrew.cmu.edu/pipermail/openslide-users/attachments/20160413/d93997f7/attachment.html>

More information about the openslide-users mailing list