FYI: if startup is too fast, IDLE fails

Jason L Tibbitts III tibbs at
Mon Mar 29 00:09:42 EDT 2010

Thought I'd mention an odd problem with idled which I've worked around
so that it gets into the list archive.

Running 2.3.16, the master starts idled without error.  However, all of
the services initially started by master would fail to contact idled and
give the following error:

  imap[23494]: error sending to idled: 3

Inspection of the source indicates that 3 is the NOOP operation, sent
during the initial ping over the socket to ensure that idled was
available.  The socket exists and permissions are OK.  A search of the
list archives turned up no relevant hits, except for one person seeing
the same error who does not seem to have received a reply.

Services started by the master later would connect to idled without

Adding another START item after idled in cyrus.conf (in this case,
syncclient) caused the problem to go away.

It looks as if master starts the services before idled is ready to
accept connections, and adding another service to the START section
delays things just enough.  This system is pretty fast (dual socket quad
core Nehalem with 48GB of RAM) but I'm sure others have run on fancier
hardware so I'm not sure what's up.

 - J<

More information about the Info-cyrus mailing list