sync_client segmentation fault when using TLS

Raphael Jaffey rjaffey at
Sun Mar 28 21:16:43 EDT 2010

Raphael Jaffey wrote:
> Dietmar Rieder wrote:
>> Hi,
>> we just updated our master + replication servers from 2.3.13 to 2.3.16 
>> and discovered, that the sync_client is dying with a segfault when it 
>> connects to the replication server which has set "allowplaintext: no".
>> We managed to trace down the problem and came up with the following 
>> patch against imap/backend.c to solve it.
>> Gernot & Didi
>> p.s.:
>> Allowing plaintext authentication by "allowplaintext: yes" on the 
>> replication server would also be an option as workarround ... but not 
>> for us :-)
> I had a working environment with a master server running on 32 bit 
> RHEL4.7 and version 2.3.13 of cyrus, and a replica running on 32 bit 
> RHEL5.4 and version 2.3.16 of cyrus.  I then upgraded the master to 
> 2.3.16 and now the sync_client segfaults immediately.  I tried testing 
> with plaintext allowed to no avail, after which I disabled TLS for the 
> sync service (syncserver_tls_cert_file: disabled) with no improvement.
> The output from tcpdump indicates that the TCP session closes down 
> immediately after the server sends the banner.
> I tried the patch supplied by Dietmar, which didn't fix the problem and 
> in addition, rendered the master non-operational.
> I take it from the lack of followup on this thread, that this is not a 
> problem experienced by the majority if any of the folks on this list.
> Has anyone else experienced anything like this?
> Any suggestions as to what might cause this before I dust off my 
> debugging skills and attempt to trace the cause?


I forgot to mention that I'm using the Invoca 2.3.16-1 package.

Also, the same problem occurs when I try to replicate between two fresh 
installations of 2.3.16-1 on two fresh installations of 32 bit RHEL5.4.


More information about the Info-cyrus mailing list