Urgent: Cyrus troube after upgrade

Simon Matter simon.matter at invoca.ch
Wed Feb 24 09:44:29 EST 2010

> Hello Adam,
>  > (a) disable selinux
> SELinux is disabled already.

I think it should even work with SELinux enabled but I've never tried.

>  > (b) make sure the cyrus user account is not disabled.
> How can I enable/disable a cyrus accounts?
> The user(s) are set as system users and identified by sasl. No mysql
> configuation.
> The system was fully working BEFORE the upgrade. Didn't do anything
> except the upgrade (which seems to have broken something).

The Invoca rpm requires that the cyrus user has /bin/bash as shell. That's
how it creates the user and I've just checked the RHEL5.4 rpm and saw that
it's the same with RedHat's package (which is based on an old version of
our Invoca package). Was the cyrus user touched somehow? It may well be
that the RedHat package doesn't need the user having the bash as shell but
the Invoca package needs it.
What does 'getent passwd cyrus' tell and what does 'rpm -Vf /var/lib/imap'


> Thank you for the help,
> MW
>> On Tue, 2010-02-16 at 15:49 +0100, Matthias Wulkow wrote:
>>> Hello,
>>> I manually upgraded cyrus 2.3.7 (CentOS 5.4) to cyrus 2.3.16.
>>> Note: I created the cyrus 2.3.16 rpm myself with the rpm src from here:
>>> http://www.invoca.ch/pub/packages/cyrus-imapd/
>>> doing just rpmbuild --rebuild xxx.rpm
>>> Now when I want to start cyrus:
>>> /etc/init.d/cyrus-imapd start
>>> or
>>> service cyrus-imapd start
>>> I get following error:
>>> cyrus-imapd Datenbanken importieren: This account is currently not
>>> available.
>>> Can somebody tell me what I now can do?
>>> The main mailbox there is user.general and I tried:
>>> /usr/lib/cyrus-imapd/reconstruct -m
>>> /usr/lib/cyrus-imapd/reconstruct -r user.general
>>> as Cyrus User.
> ----
> Cyrus Home Page: http://cyrusimap.web.cmu.edu/
> Cyrus Wiki/FAQ: http://cyrusimap.web.cmu.edu/twiki
> List Archives/Info: http://asg.web.cmu.edu/cyrus/mailing-list.html

More information about the Info-cyrus mailing list