Sieve script parse error problem

Ken Murchison murch at
Mon Oct 24 13:54:03 EDT 2005

Andreas Haumer wrote:
> Hash: SHA1
> Hi!
> Another followup to my own mail, as I now have additional
> information.
> Andreas Haumer schrieb:
>> Hi!
>> As after two weeks I haven't got a single reply to my problem report
>> and I'm still hunting this problem I would like to bring up the issue
>> again.
>> I would like to add that I have sieve working fine on other installations
>> with both cyrus-imapd-2.2.8 and cyrus-imapd-2.2.10.
> [...]
>> But with cyrus-imapd-2.2.12 I can't get sieve to work as I always
>> get the error mentioned below.
> Comparing the differences between those systems I found
> that on the installations with a working cyrus-imapd I
> used bison-1.34 to compile the package (e.g. translate
> the sieve.y file) whereas with the newer cyrus-imapd-2.2.12
> I also used the newer bison-2.1 to compile the package
> I just tried to compile timsieved from cyrus-imapd-2.2.12
> without re-creating sieve.c and sieve.h from sieve.y (by
> touching sieve.c and sieve.h before running make) and
> this gave me a timsieved binary which actually accepts
> my small testing sieve script without complaints!
> So it currently looks like the reason for the problems I
> see is an incompatibility between sieve.y and the newer
> bison!
> For now I think I can live with this workaround (touch
> the sieve.[ch] files provided by the cyrus-imapd source
> package) but I guess someone has to look at the sieve.y
> file to see what this incompatibility might be (or perhaps
> it's even a bug in bison?)
> Any comments?

I've never tried using any of the Bison 2.x code with Cyrus, and I'm not 
sure that anyone else at CMU has either.

Kenneth Murchison
Systems Programmer
Carnegie Mellon University

More information about the Info-cyrus mailing list