cyrus-imapd appears dead

Michael Ballard baleful at
Sat Sep 4 14:12:22 EDT 2004

Alexander Dalloz <alexander.dalloz at> wrote ..
> Am Sa, den 04.09.2004 schrieb Michael Ballard um 2:07:
> > System: Fedora Core 2
> > My problem is simple. cyrus-imapd doesn't appear to be working. With
> all my config files as they are, I receive
> > E-mail, but must use Webmin or SSH to check it. I can't get it through
> IMAP. Mozilla Mail reports no messages
> > on the server. Squirrelmail reports:
> >
> > "ERROR:
> > ERROR : Could not complete request.
> > Query: CREATE "mail/Sent"
> > Reason Given: Invalid mailbox name"
> You obviously have more than 1 problem. One is that Sendmail is not
> configured correctly. I told you already the correct entries. Why don't
> you did set them properly?
> dnl #define(`confLOCAL_MAILER', `cyrusv2')dnl
> dnl #define(`confLOCAL_MAILER_PATH', `/etc/mail/')
> dnl #define(CYRUSV2_MAILER_ARGS', FILE /var/lib/imap/socket/lmtp')dnl
> Who told you that? The first line is correct. The second line does not
> make any sense. The third line is false and must lead
> to complaints by m4 when generating the
> dnl (`CYRUSV2_MAILER_ARGS', `FILE /var/lib/imap/socket/lmtp')dnl
> Pay attention to proper parentheses.
> > I've used cyradm to create the mailboxes user.baleful and user.mballard
> and all the others, but same error all across.
> > I've tried making user.baleful.Sent and that returns the same error in
> Squirrelmail.
> It would be of much more help if you would post syslog messages by
> Cyrus-IMAPd then by Squirrelmail. If you have problems to set up
> Squirrelmail then this is the false forum.
> > What I originally had was Fedora Core 1 with uw-imap, and it worked.
> Only problem was that I couldn't figure out smtp
> > relaying (based on authentication). From what I understood, I needed
> this cyrus-imapd and cyrus-sasl thinggy...which
> > have been implemented into FC2. So I figure, hey! No problem, now it
> will all work right! But it never has.
> That is wrong. Cyrus-IMAPd is not needed for SMTP AUTH. You have to
> differ between Cyrus-IMAPd and Cyrus SASL. The last one is needed by
> Sendmail to offer SMTP AUTH.
> > When I tweak my file and include the lines that are commented
> out by
> > 
> > dnl #Added by baleful for cyrus-imapd
> > 
> > I get no mail at all. I can still send, but cannot receive. Then I take
> those lines back out, and get my E-mail again.
> See what I wrote above.
> > I don't know if I'm being very clear or not, but I hope I am, because
> I'm at my wits' end with this; and I start school soon,
> > which will be grueling enough.
> First correct the Sendmail setup, so that Sendmail and Cyrus-IMAPd are
> really communicating. If that is not enough then post an URL with
> logfile entries showing the error messages by Sendmail and/or
> Cyrus-IMAPd, not Squirrelmail.
> Alexander
> P.S. Do you really need Cyrus-IMAPd? I feel you are a better candidate
> for dovecot which ships with Fedora as well and is easier to set for
> people with few experiences.
> -- 
> Alexander Dalloz | Enger, Germany | GPG key 1024D/ED695653 1999-07-13
> Fedora GNU/Linux Core 2 (Tettnang) kernel 2.6.8-1.521smp 
> Serendipity 02:34:23 up 4 days, 23:51, load average: 0.64, 0.54, 0.67 
> ---
> Cyrus Home Page:
> Cyrus Wiki/FAQ:
> List Archives/Info:

OK, fixed the file (posted it on my URL)...still the same thing though. So I tried E-mailing myself from my hotmail account, and it's stuck in the mail queue.

Executed from my /var/log/ directory:

[root at thesewer log]# tail maillog
[root at thesewer log]# tail imapd.log
[root at thesewer log]# tail messages

So I seem to have not log entries...

More information about the Info-cyrus mailing list