Cyradm under 2.2.3 and mailboxes with spaces SOLVED

Roland Pope rpope at
Sun May 16 19:01:24 EDT 2004

On Saturday, 15 May 2004, Rob Siemborski Wrote:
> > I am running cyrus-imapd 2.2.3 under RedHat ES 3.0 and I can't seem to
> > create mailboxes with spaces in them using cyradm. Under 2.1.15 I had no
> > problem creating such mailboxes.
> Works for me:
> sourcefour:i386_rh80:~> cyradm cyrus
>> cm "inbox.test me"
> Could you generate a protocol dump and show me what name is actually being
> attempted here?
I have created a directory for the admin user in the telemetry logs
directory, but the cyradm command is not getting to the point where it
passes it to IMAP.
It is syntax-ing before then because it appears to be ignoring the quotes.
It appears to be a problem related to the LANG variable, as RedHat by
default uses 'en_US.UTF-8', which is a UNICODE language. If I set LANG='C',
the problem goes away.
If I run a strace of cyradm, I can see that it is calling
"/usr/lib/perl5/5.8.0/unicore/lib/" which is doesn't do when


Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list