Cyradm under 2.2.3 and mailboxes with spaces SOLVED

Sebastian Hagedorn Hagedorn at
Mon May 17 03:14:25 EDT 2004

--On Montag, 17. Mai 2004 11:01 Uhr +1200 Roland Pope <rpope at> 

> I have created a directory for the admin user in the telemetry logs
> directory, but the cyradm command is not getting to the point where it
> passes it to IMAP.
> It is syntax-ing before then because it appears to be ignoring the quotes.
> It appears to be a problem related to the LANG variable, as RedHat by
> default uses 'en_US.UTF-8', which is a UNICODE language. If I set
> LANG='C', the problem goes away.
> If I run a strace of cyradm, I can see that it is calling
> "/usr/lib/perl5/5.8.0/unicore/lib/" which is doesn't do when
> LANG='C'??

I don't know the details, but I've read that Perl 5.8.x, where x < 3, has 
issues with Unicode. Chances are that it'll work fine if you upgrade your 
Perl installation to 5.8.3. We still have Perl 5.6.1 and don't yet use 
UTF-8, so I don't know for sure.

Greetings, Sebastian Hagedorn
Sebastian Hagedorn M.A. - RZKR-R1 (Gebäude 52), Zimmer 18
Zentrum für angewandte Informatik - Universitätsweiter Service RRZK
Universität zu Köln / Cologne University - Tel. +49-221-478-5587
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 194 bytes
Desc: not available
Url :

More information about the Info-cyrus mailing list