Authentication error SOLVED

Andrew Morgan morgan at
Fri Jan 9 14:07:08 EST 2004

On Fri, 9 Jan 2004, Christiano Anderson wrote:

> Hey guys,
> I've finally found out the problem, and believe, it's really a bug, either
> of Cyrus or SASL 2.
> The problem happens only when I have my NSS using LDAP, through these
> lines in nsswitch.conf:
> --
> passwd:         compat ldap
> group:          compat ldap
> shadow:         compat ldap
> ---
> If I take 'ldap' out of that file, Cyrus works pretty well, like it should
> do.
> For me, actually, it's not a problem at all, because I don't really need
> to have NSS using LDAP, once this machine is used only for that stuff.
> But it's a bug, and it must be fixed ASAP.
> I've tried both using SASL via PAM and via LDAP direcly. Same problem.
> I don't know why that problem happens. There is no an appearant cause.

I had this problem until I rebuilt the debian libldap2 package to not link
against libsasl7.  In debian stable, an older version of libsasl is used.
When one of the Cyrus processes links in both libsasl2 (the newer version,
paradoxically) and libsasl7 (when it does a user lookup that hits ldap),
it will segfault.

I rebuilt the debian stable libldap2 and removed "--with-cyrus-sasl" from
the configure options in the package.


More information about the Info-cyrus mailing list