Problems with make all CFLAGS command

David Brown dbrowng1 at
Tue Jan 27 11:18:12 EST 2004


I'm still trying to digest your last email.  Not sure
how to put this include into the Makefile.  Anyway,
here are my followup actions taken and a few possible


*** FollowUp ***

1) Tried configure switch "--without-krb" but no
2) Tried configure switch "--without-krb5" but no
3)Tried [./configure --with-auth=unix
--with-krb=/usr/kerberos/include], no luck.
4)Tried [./configure --with-auth=unix
--with-krb=/usr/kerberos/gssapi], no luck.
5) Per suggestion from info-cyrus message board,
[/configure --with-auth=unix
--with-krb=/usr/kerberos], no luck.
6) Installed cyrus-sasl-2.1.17 quick and dirty, but no
	 cd (directory it was untarred into)
	 make install
	 ln -s /usr/local/lib/sasl2 /usr/lib/sasl2
7) Changed PATH in /root/.bash_profile to try to point
to kerberos, no luck.
8) Installed latest version of Berkeley DB, no luck.

*** Options ***

1) Reboot to see if fresh SASL or BerkeleyDB may need
it to work, then retry.
2) Go ahead and start fresh with latest stable kernel
(2.6?).  (Would this solve any problems?)
3) Change Makefile to add include (need to learn how).

4) Other ideas?

Thanks again,

--- Craig Ringer <craig at> wrote:
> On Tue, 2004-01-27 at 23:02, David Brown wrote:
> > *  Was krb5 already properly installed when I
> > installed Red Hat 9a, or do I need to re-install
> or
> > reconfigure it somehow?
> I think it's installed if you install the openssl
> development libraries.
> > * Why am I doing this anyway when I'm not
> concerned
> > about having Kerberos at the moment?  I tried
> > --without-krb and --without-krb5 options but got
> the
> > same results.  Can't I leave out Kerberos?
> The problem as I understand it is that the openssl
> development tools
> have been built with kerberos support. Despite the
> fact that you're not
> using kerberos, ssl.h needs kssl.h, and kssl.h needs
> krb5.h; as such you
> at least need the kerberos includes to be available.
> I must say that I'm surprised the #include <kssl.h>
> in ssl.h isn't
> #ifdef'ed to only be required when kerberos will be
> used. Then again, my
> C programming knowledge is poor to nil.
> > * Could this have something to do with SASL
> > configuration?
> I really couldn't tell you. I doubt it - I think the
> problem is the way
> RH have configured their openssl libs - but I'm not
> even remotely sure.
> If the suggestions offered above don't solve your
> problem then... well,
> frankly I can't remember how I worked around it.
> Perhaps editing the
> Makefile to add the include manually might do the
> trick?
> Craig Ringer

Do you Yahoo!?
Yahoo! SiteBuilder - Free web site building tool. Try it!

More information about the Info-cyrus mailing list