Problems with make all CFLAGS command

Mike O'Rourke mjoop at
Tue Jan 27 12:09:53 EST 2004

>>> David Brown <dbrowng1 at> 01/27/04 05:18pm >>>

I'm still trying to digest your last email.  Not sure
how to put this include into the Makefile.  Anyway,
here are my followup actions taken and a few possible


*** FollowUp ***

1) Tried configure switch "--without-krb" but no
2) Tried configure switch "--without-krb5" but no
3)Tried [./configure --with-auth=unix
--with-krb=/usr/kerberos/include], no luck.
4)Tried [./configure --with-auth=unix
--with-krb=/usr/kerberos/gssapi], no luck.
5) Per suggestion from info-cyrus message board,
[/configure --with-auth=unix
--with-krb=/usr/kerberos], no luck.
6) Installed cyrus-sasl-2.1.17 quick and dirty, but no
	 cd (directory it was untarred into)
	 make install
	 ln -s /usr/local/lib/sasl2 /usr/lib/sasl2
7) Changed PATH in /root/.bash_profile to try to point
to kerberos, no luck.
8) Installed latest version of Berkeley DB, no luck.

*** Options ***

1) Reboot to see if fresh SASL or BerkeleyDB may need
it to work, then retry.
2) Go ahead and start fresh with latest stable kernel
(2.6?).  (Would this solve any problems?)
3) Change Makefile to add include (need to learn how).

4) Other ideas?

Hi David,

>From a quick reading of the kssl.h file, you might try adding
"-DOPENSSL_NO_KRB5" to your CFLAGS and CPPFLAGS variables. This seems to
cause most of the kssl.h file to be skipped.

HTH, Mike

More information about the Info-cyrus mailing list