Cyrus install problem

Craig Ringer craig at
Thu Jan 29 07:05:02 EST 2004

On Thu, 2004-01-29 at 19:23, David Grant wrote:
> Ok, here is what happens when I make it. I'm running RedHat ES 3. I tried it
> without any options. The configure was: ./configure
> --with-openssl=/usr/include/openssl

Great; that's more useful. I you post that level of information when
asking a question, you're much more likely to get a response, get a
better response, and probably get it faster. It makes it so much easier
to (a) figure out if it's related to a previous problem and (b) figure
out what might be going on.

It also tells me that your problem is almost certainly the same one that
I ran into a while ago - a problem that was discussed over the last two
days on this mailing list, bringing me to the other thing you should
really do when asking for help on mailing lists. 

Search the list archives. Always. And mention that you've done so. If I
see "I had a look on google and the archives, but couldn't see anything
about this" I'm _much_ more inclined to spend my time trying to help
someone out, because it shows they've made a certain effort to resolve
the issue themselves.

In your situation, the key errors from the log you posted are:

> In file included from /usr/include/openssl/ssl.h:179,
> /usr/include/openssl/kssl.h:72:18: krb5.h: No such file or directory

Please look up the cyrus archives and read my answers to the previous
time this question was asked. The thread is entitled "Problems with make
all" and the first message is from David Brown on 27 Jan 2004.

A suggestion to the friendly list-admin: is there any chance of having
that URL appended to all posts on the list? I know it's ugly, but it
does seem to help.

Craig Ringer

More information about the Info-cyrus mailing list