pwcheck doesn't work after system restart

Mark Keasling mark at
Wed May 21 22:10:42 EDT 2003


The Cyrus learning curve is fairly steep.  It requires patience.
Lots of it.  You may have to take out a loan. :) I'm still no expert.

Cyrus 1.5.x is fairly old.  Assuming an upgrade is available for your
system you might consider a more recent version.

If you don't mind, could you post your imapd.conf, cyrus.conf and log
files so we can see your setup and log output?  Sanitize hostnames and
username if you feel they are sensitive.  If you haven't already, set
the syslog level to debug to get a more detailed log.  Also as you try
different things record the commands and output so you know what you've
done and what happened.  It may come in handy later.

Do you remember how pwcheck was started the first time?

Check the /etc/init.d/pwcheck script and trying running pwcheck via
the command line.  It may produce informative output.  If I remember
correctly, pwcheck should be started by the root user so it has access
to the shadow file.  It may not run otherwise; but, I assume that you
know that and are already running it as root.

That's about it off the top of my head where hair once grew. :)

On Thu, 22 May 2003 11:25:24 +1000, Stewart <stewart at> wrote...
> Greetings..
> system: debian 3.0 woody PPC
> cyrus imapd v1.5.19 (installed with apt, not compiled)
> I'm trying cyrus for the first time this week, and having fun riding 
> the learning curve. :) All going OK so far except last night i switched 
> the machine off and after starting up again this morning i can't 
> connect due to 'cannot connect to pwcheck server' , as it says in the 
> logs.
> I can't for the life of me work out why. there is no indication of any 
> errors, apart from 'can't connect' in any of the logs. i've tried 
> /etc/init.d/pwcheck start but there is no pwcheck showing up in the 
> process list. have tried restarting xinetd. have tried removing the 
> /var/state/pwcheck files (this is like a pid or lockfile, no?)
> but all to no avail. i'm running out of ideas. am i right in presuming 
> that as pwcheck is a daemon it ought to show up in the ps list if it's 
> running? or does it only run when actually being used?
> i'm also a tad confused because the docs say cyrus uses sasl auth by 
> default but my system (up until this morning) was clearly using local 
> UNIX user auth - ie /etc/passwd.
> any suggestions gratefully received...
> thanks,
> ..S.

Mark Keasling <mark at>

More information about the Info-cyrus mailing list