openslide_read_region filling buffer with 0's for Mirax

Terry Wilson twilson7755 at
Sun Apr 12 12:53:07 EDT 2020

Using the original .mrxs file was the first thing I tried but it resulted
in other errors being generated so I thought maybe there was something in
that file that also needed to be changed.  When using the original file
with the generated data folder (of the same name), I am able to open the
slide but calling any other openslide API results in a "Slide position file
not of the expected size" error ... any ideas?

So next I moved on to see if I could try and step through the code but ran
into various issues:

   - I saw that the /bin folder of the openslide windows distribution
   included *.dll.debug files ... so I tried renaming all of these to just
   *.dll and run my application, however, it will not start up using these
   dll's, just crashes trying to load the application ... should these
   *.dll.debug files not work?
   - Even if the above did work, there are no PDB files so I'm guessing I
   can't debug this using Visual Studio?
   - Next tried to build my own openslide libraries following the
   instructions from the openslide site for building natively on windows (i.e.
   install cygwin, etc.).  The build runs for a little while before crashing:
      - [ 63%] Linking C executable ../../../bin/opj_compress.exe
      collect2: fatal error: ld terminated with signal 11 [Segmentation
      fault], core dumped
      compilation terminated.
      make[2]: *** [src/bin/jp2/CMakeFiles/opj_compress.dir/build.make:205:
      bin/opj_compress.exe] Error 1
      make[2]: *** Deleting file 'bin/opj_compress.exe'
      make[2]: Leaving directory
      make[1]: *** [CMakeFiles/Makefile2:228:
      src/bin/jp2/CMakeFiles/opj_compress.dir/all] Error 2
      make[1]: Leaving directory
      make: *** [Makefile:152: all] Error 2
      Failed: make $parallel (line 464)

I would prefer NOT to have to build my own openslide libraries, so
hopefully someone can let me know why my simple test app won't even start
when trying to use the *.dll.debug dll's?  Of course I would prefer if I
didn't have to step through the code at all, but doesn't seem like I am
going to be able to avoid that at this point :-(



On Sat, Apr 11, 2020 at 8:03 AM T. N. <ca95129 at> wrote:

> I also tried playing around with their converter ... when I converted MRXS
> to MRXS, it generated the corresponding data files and directory but I
> didn't see any new 'mrxs' file being created ... so wasn't able to try
> OpenSlide on the converted slide ... any ideas on that?
> Use the original .mrxs file with the converted data files (rename it to
> match your converted data folder name).
> T.
> _______________________________________________
> openslide-users mailing list
> openslide-users at
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the openslide-users mailing list