cyrus-imapd not starting after upgrade

Daniel Bareiro daniel-listas at
Tue Jan 15 13:05:50 EST 2019

Hi, Michael. Thanks for your reply.

On 15/1/19 13:54, Michael Menge wrote:

>> I'm not sure what the problem is but that "invalid magic header" makes
>> me think that maybe it changed the header format of
>> /var/lib/cyrus/tls_sessions.db and the migration process did not do the
>> corresponding conversion. Can that be the reason why it doesn't start or
>> I'm missing something else? Any ideas that can bring more light?

> some defaults for database format have changed between 2.4 and 2.5 but this
> is automatically handled.

Thanks for confirm.

> You Problem lies in
> Jan 14 23:10:46 mail cyrus/master[5311]: cannot find executable for
> service 'nntp'
> Jan 14 23:10:46 mail cyrus/master[5311]: exiting
> Either the executables are installed in the wrong place, or cyrus was
> compiled/packaged without news support. You can comment out nntp in 
> /etc/cyrus.conf to try to start without running an nntp server

It seems that support for NNTP was separated in Debian Stretch regarding
to Debian Jessie. I don't use NNTP, so I simply commented out the "nntp"
line in the /etc/cyrus.conf configuration file. I think I had tried that
before, although it seems to me that time I forgot to do it also with
the "nntps" line.

Then I tried again to start the service and now the error changed:

Jan 15 14:13:59 mail cyrus/master[20737]: cannot find executable for
service 'http'

But I'm not sure if this has been included in another separate package:

root at mail:/var/run/cyrus/socket# aptitude search ^cyrus
idA cyrus-admin
        - Cyrus mail system - administration tools
c   cyrus-admin-2.4
p   cyrus-caldav
        - Cyrus mail system - CalDAV and CardDAV support
idA cyrus-clients
        - Cyrus mail system - test clients
c   cyrus-clients-2.4
idA cyrus-common
        - Cyrus mail system - common files
i   cyrus-common-2.4
        - Cyrus mail system - common files [dummy package]
p   cyrus-dev
        - Cyrus mail system - developer files
p   cyrus-doc
        - Cyrus mail system - documentation files
idA cyrus-imapd
        - Cyrus mail system - IMAP support
c   cyrus-imapd-2.4
p   cyrus-imspd
        - Internet Message Support Protocol daemon
p   cyrus-murder
        - Cyrus mail system - proxies and aggregator
p   cyrus-nntpd
        - Cyrus mail system - NNTP support
p   cyrus-pop3d
        - Cyrus mail system - POP3 support
p   cyrus-replication
        - Cyrus mail system - replication
p   cyrus-sasl2-doc
        - Cyrus SASL - documentation

The fact is that if I also comment out the "http" line, now it seems
that I get a syntax error:

Jan 15 14:14:28 mail cyrus/master[20778]: configuration file
/etc/cyrus.conf: bad character '_' in name on line 101
Jan 15 14:14:28 mail cyrus/master[20778]: exiting

I think the configuration file already came with the "squatter_a" line
and I just removed the comment. Unless this is a bug in the
configuration file provided by Stretch for Cyrus 2.5.10:

 99         # reindex all mailboxes (fulltext) daily
100         # DGB - 20190114
101         squatter_a      cmd="/usr/sbin/cyrus squatter" at=0517

>> The associated problem is that because of this it seems that Postfix can
>> not deliver the mails since there is no /var/run/cyrus/socket/lmtp.

> As cyrus aborted the start there is no process listening

That's what I thought :-)

Thanks for your time.

Kind regards,

-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 195 bytes
Desc: OpenPGP digital signature
URL: <>

More information about the Info-cyrus mailing list