Upgraded cyrus 2.5.6: lmtpd segfaults

Dave McMurtrie dave64 at andrew.cmu.edu
Mon Nov 2 14:06:42 EST 2015

On Mon, 2015-11-02 at 19:11 +0100, Stefan G. Weichinger via Info-cyrus
> Am 2015-11-02 um 14:06 schrieb Stefan G. Weichinger via Info-cyrus:
> > 
> > gentoo server here,
> > 
> > yesterday I upgraded cyrus-imapd from 2.4.x to 2.5.6
> > Alongside I reinstalled glibc, cyrus-sasl, postfix ... and corrected all
> > the new config options etc in cyrus.conf etc
> > 
> > I now see problems with lmtpd.
> I tried multiple things over the last few hours, even upgraded the
> kernel and rebuilt all(?) the relevant packages.
> I still have over 100 emails in the queue which don't get delivered to
> cyrus, and I still get the segfaults.
> Could someone pls advise how to proceed and maybe debug this issue?

We recently upgraded our MX servers to what will eventually be 3.x and
had a series of issues with lmtpproxyd (which is actually a link to
lmtpd).  I'm not sure how much of the code is common with what's in the
2.5.x releases, but Ken (cc'd on this) managed to track down and fix our
sigsegv issues.  Ken, do you know if the things you fixed are present in
the 2.5.x code as well?

More information about the Info-cyrus mailing list