XFER problems with 2.4.6

Simon Amor simon.amor at daily.co.uk
Tue Feb 15 10:26:38 EST 2011

On 15 Feb 2011, at 13:42, karavelov at mail.bg wrote:
> Feb 11 14:41:10 stor5 cyrus/imap[11569]: LOSTQUOTA: unable to record  
> quota file xxxx.xx!user.000
> Feb 11 13:23:47 stor5 cyrus/imap[11445]: Deleted mailbox xxxx^xx! 
> user^000^pay

This looks similar to when I tried to migrate a mailbox from 2.4.6  
back to 2.3.12, there were some weird log entries that had mismatched  
'.' vs '^' substitutions. unixhierarchysep is set to on for both  

In your example, it says xxxx.xx!user.000 for the quota, but then  
deleting xxxx^xx!user^000 - this is the same thing that I had. After  
the XFER failed, dumping the mailboxes.db on the mupdate server  
revealed that there were duplicated mailboxes - one in each format.

The mailbox in question was xx.yy at xxxx.co.uk (masked of course)

cyrus at mupdate $ /usr/lib/cyrus-imapd/cyr_dbtool /var/lib/imap/ 
mailboxes.db skiplist show



The two different formats were associated with different servers, the  
first set was shown as being on the 2.3.12 server where it had failed  
to move it, tried to back out the move, and failed with that too. The  
second (correctly formatted) ones were shown as being on the 2.4.6  
server. The mailbox contents were actually still on the 2.4.6 server  
so it was a matter of removing the broken entries using cyr_dbtool.

This was 2.4.6 -> 2.3.12 so maybe there's some discrepancy in what  
2.4.6 sends vs what 2.3 and 2.4 expect?

Simon Amor

More information about the Info-cyrus mailing list