Compiling and libdb

steffo76 at steffo76 at
Wed Dec 21 04:07:08 EST 2011


I have a problem that someone might have a solution for. I have two servers running cyrus imap 2.3.14 which is built against libdb-4.2. I would like to upgrade them to 2.4.12. 

As the indexes need to be upgraded I would like to test this beforehand so I restored the mail to a test machine and ran cyrus-imap 2.4.12. Unfortunately I got "IOERROR: opening index System I/O error" for each and every mailbox. I was hoping that this might be to the fact that on this machine the imapd was built against libdb-4.7 which is the version installed on the system but the index files where created by an imapd using libdb-4.2. Permissions on the files and directories are correct.

So I downloaded libdb-4.2 installed it and tried to build cyrus-imap 2.4.12 against it to no avail- no matter what I tried it built against libdb-4.2 but linked against libdb-4.7 ("incorrect version of Berkeley db: compiled against 4.2.52, linked against 4.7.25"). I used --with-bdb --with-bdb-libdir --with-bdb-incdir LDFLAGS und CPPFLAGS. Nothing. 

So I thought what the heck, let's reconstruct the mailboxes but I can't seem to get them to. Reconstruct runs without an error but the mailboxes are being shown as empty. What am I missing ?

NEU: FreePhone - 0ct/min Handyspartarif mit Geld-zurück-Garantie!		
Jetzt informieren:

More information about the Info-cyrus mailing list