Since updating to 2.4.10: Mailbox has an invalid format

Marc Muehlfeld Marc.Muehlfeld at
Tue Aug 30 03:03:41 EDT 2011


because of problems (See thread: "IOERROR: zero index/expunge record" here on 
the list about 1.5 month ago) I was told to upgrade from 2.3.16 (Scientific 
Linux 6.1 shipped RPM) to the latest 2.4.10 version (self compiled).

Yesterday night I upgraded and since this morning my phone hasn't stop 
ringing, because many user are getting "Mailbox has an invalid format". The 
log says:

Aug 30 08:45:57 chromosom imap[11591]: IOERROR: refreshing index for 
user.muehlfeld.IMGM_Extern.GbR: Success
Aug 30 08:45:57 chromosom imap[11591]: IOERROR: locking index 
user.muehlfeld.IMGM_Extern.GbR: Mailbox has an invalid format

When I reconstruct, I get messages like:
user.muehlfeld.IMGM_Extern.GbR: failed to read index header
user.muehlfeld.IMGM_Extern.GbR uid 805 found - adding
user.muehlfeld.IMGM_Extern.GbR uid 806 found - adding
user.muehlfeld.IMGM_Extern.GbR uid 807 found - adding

I run a recursive reconstruct on the concerned mailboxes (while no one was 
accessing the it). But meanwhile I had some mailboxes I had repaired about 1h 
ago, that already show this message again.

On a few mailboxes I can't run even a reconstruct any more - I only get:
fatal error: failed to mmap new message file

In this case I had to remove cyrus.cache, cyrus.cache.NEW, cyrus.index, 
cyrus.index.NEW. The *.NEW files weren't there before I run "reconstruct".


More information about the Info-cyrus mailing list