Weird sync problems in 2.4.0

Bron Gondwana brong at
Wed Oct 13 15:06:56 EDT 2010

Are you reconstructing with -G? My best guess is the original file is corrupt, but without -G it won't notice!

steffo76 at wrote:

>Hello everybody,
>I have a problem regarding the synchronisation in 2.4.0. I installed 2.4.0 on two test servers where 2.3.16 was installed. The imapd on the replica hasn't been running for a while. After the two where online I tried to replicate from the master to the replica and ran into some problems. 
>If I try to sync the mailbox user.tester to the replica using sync_client -v -m user.tester I get
>MAILBOXES user.tester
>Error from do_mailboxes(): bailing out!
>On the replica I can see the following error in syslog:
>IOERROR: failed to parse /path/to/sync./18755/991ebe63638ae2e25b9f081aa5b3d78f9380309b
>Failed to append file user.tester 29
>I ran reconstruct on the mailbox for a dozen times using -G -r and -f but that didn't help. 
>Browsing a bit through the source code (I am not a programmer) I found the message probably gets generated in message_parse in imap/message.c. I inserted a syslog message telling me which file it was trying to open and a sleep, recompiled and installed and tried to find the file the next time- it wasn't there, the directory where it should have been was empty. Using strace I can see that the sync_client is sending (amongst other stuff) "APPLY MESSAGE" whith a message and shortly after that a "APPLY MAILBOX" in which a GUID appears which is identical to the name of the file which is missing on the replica. 
>How do I resolve that and is there a document describing the sync protocol in detail ?
>GMX DSL Doppel-Flat ab 19,99 €/mtl.! Jetzt auch mit 
>gratis Notebook-Flat!
>Cyrus Home Page:
>List Archives/Info:

Sent from my Android phone with K-9 Mail. Please excuse my brevity.

More information about the Info-cyrus mailing list