strange issue - observed after running reconstruct

Sebastian Hagedorn Hagedorn at
Thu Oct 7 03:58:20 EDT 2010

--On 7. Oktober 2010 13:01:00 +0530 "Vishwanath T. K." <vishytk at> 

> For migration of mailbox (including /var/lib/imap and /var/spool/imap), we
> are using rsync (rsync -avpzH --progress --stats). The total size of mail
> box (/var/spoo/imap) is 320GB on the old hardware. After rsync is finished
> running we see the size of /var/spool/imap on the new hardware to be
> 320GB. After the rsync operation, when reconstruct is run and finished
> the size of /var/spool/imap is reduced to around 190GB. We find that for
> some mail boxes, the number of messages is reduced (getting deleted)
> drastically. For example, before reconstruct, if a particular user is
> having more than 100 messages, after reconstruct we are observing that
> the number of messages are very few (few 10's). This is happening for
> random users. We tried reconstruct on the older hardware also, and found
> the same behaviour. We have also tried with cyrus-imapd-2.3.16 on the new
> hardware and saw the same result.
> Can someone explain/suggest what is happening here and is this a possible
> bug in reconstruct (cyrus-imapd)

"reconstruct" expunges messages that are marked as deleted, unless you 
specify the -k flag. That could explain it.
     .:.Sebastian Hagedorn - RZKR-R1 (Gebäude 52), Zimmer 18.:.
                 .:.Regionales Rechenzentrum (RRZK).:.
.:.Universität zu Köln / Cologne University - ✆ +49-221-478-5587.:.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pkcs7-signature
Size: 5292 bytes
Desc: not available
Url : 

More information about the Info-cyrus mailing list