strange issue - observed after running reconstruct

Vishwanath T. K. vishytk at
Thu Oct 7 03:31:00 EDT 2010


First my setup details:

CentOS 5.5, cyrus-imapd-2.3.15 (also tried 2.3.16)

We are migrating from an old server hardware to a new server hardware. While
the old hardware was of 32-bit architecture, the new one is 64-bit
architecture. The versions of software on the new hardware is same as that
on the old hardware.

For migration of mailbox (including /var/lib/imap and /var/spool/imap), we
are using rsync (rsync -avpzH --progress --stats). The total size of mail
box (/var/spoo/imap) is 320GB on the old hardware. After rsync is finished
running we see the size of /var/spool/imap on the new hardware to be 320GB.
After the rsync operation, when reconstruct is run and finished the size of
/var/spool/imap is reduced to around 190GB. We find that for some mail
boxes, the number of messages is reduced (getting deleted) drastically. For
example, before reconstruct, if a particular user is having more than 100
messages, after reconstruct we are observing that the number of messages are
very few (few 10's). This is happening for random users. We tried
reconstruct on the older hardware also, and found the same behaviour. We
have also tried with cyrus-imapd-2.3.16 on the new hardware and saw the same

Can someone explain/suggest what is happening here and is this a possible
bug in reconstruct (cyrus-imapd)

-------------- next part --------------
An HTML attachment was scrubbed...

More information about the Info-cyrus mailing list