Can't connect to timsieved (2.3.14)

Rich Wales richw at
Wed May 27 21:14:48 EDT 2009

I seem to have worked around my earlier problem.

For some reason, the Cyrus::SIEVE::managesieve Perl package didn't get
properly compiled/installed when I first built Cyrus 2.3.14.  I remade
and installed this package and the "sieveshell" script, and sieveshell
works for me now.  And, using sieveshell, I am able to contact my mail
server and manipulate Sieve scripts on it.

So, my original, immediate problem appears to be solved.  Sorry it was
such a bizarre problem that no one else out there seemed to have any
idea what to say about it.

The bug may, in fact, be in "sieve-connect", not in the Cyrus code.
But I'm still suspicious of a situation where sieve-connect may have
done something which caused a timsieved process to crash mysteriously
-- something which no client should be able to do to a server process.
But whatever . . . .

Rich Wales  /  richw at  /  richw at

More information about the Info-cyrus mailing list