Can't connect to timsieved (2.3.14)

Rich Wales richw at
Wed May 27 16:44:23 EDT 2009

I'm still having this problem, though it appears to be intermittent.

I was able, just now, to do "sivtest -v localhost" on my Cyrus server,
and authenticate, and issue a Managesieve command (listscripts) and
get a valid reply.

But "sieve-connect --debug localhost" still fails with "no line read,
connection dropped?" right after the AUTHENTICATE command.  And when
I tried "sivtest -v localhost" again, it failed right after saying
"Asking for capabilities again since they might have changed" --
sometimes spewing out some unprintable garbage before complaining
of some sort of SASL problem -- sometimes simply saying "failure:
prot layer failure".

This worked fine before I upgraded to Cyrus 2.3.14.  Is something
known to be broken in 2.3.14?  Has anyone else out there ever seen
anything like this?  What should I try next?  I'm stuck here and
would be very grateful for any help.

Rich Wales  /  richw at  /  richw at

More information about the Info-cyrus mailing list