Problems upgrading from cyrus 2.1.18 to 2.2.13 on debian etch

Steinar Bang sb at
Tue Nov 27 13:49:56 EST 2007

>>>>> Steinar Bang <sb at>:

> When I try to run the following command line from
> /usr/share/doc/cyrus-common-2.2/README.Debian.database.gz 

> /usr/sbin/cvt_cyrusdb /var/lib/cyrus/deliver.db db3 /var/lib/cyrus/temp.db flat

> I get the following error message:

> fatal error: unknown old backend

> What's unknown here?  The "db3" argument?  Or the format of the
> deliver.db file?

The "db3" argument, appearently. 

I tried:
/usr/sbin/cvt_cyrusdb -h
/usr/sbin/cvt_cyrusdb: invalid option -- h
Usage: /usr/sbin/cvt_cyrusdb [-C altconfig] <old db> <old db backend> <new db> <new db backend>
Usable Backends:  berkeley, berkeley-nosync, berkeley-hash, berkeley-hash-nosync, flat, skiplist, quotalegacy

So I tried:
$ /usr/sbin/cvt_cyrusdb /var/lib/cyrus/deliver.db berkeley /var/lib/cyrus/temp.db flat
Converting from /var/lib/cyrus/deliver.db (berkeley) to /var/lib/cyrus/temp.db (flat)
fatal error: can't open old database

I'm getting this feeling of deja vu all over again... I wonder if I ran
into something similar when upgrading from 1.5 to 2.* once upon a

Can't find it in the archives, though.

More information about the Info-cyrus mailing list