One more attempt: stuck processes

Sebastian Hagedorn Hagedorn at
Wed Nov 14 11:49:10 EST 2007

--On 14. November 2007 09:30:45 -0600 Gary Mills <mills at> 

> On Wed, Nov 14, 2007 at 04:15:13PM +0100, Sebastian Hagedorn wrote:
>> I've brought up this topic before. We've been running cyrus-imapd very
>> happily for several years. Yet there's one issue that none of the
>> updates  have resolved. The last time I reported it we were running
>> 2.2.12. Now  we're running 2.3.8, but the issues is the same: POP and
>> IMAP processes  that use TLS/SSL get "stuck". My observations point
>> towards dropped dial-up  connections as the cause. Here's an example:
> Have you tried setting `tls_session_timeout' to zero in imapd.conf to
> disable caching of TLS sessions?

No. While it's possible that there's some connection, I don't see it from 
the stack trace. I think I'd like some indication from one of the 
developers that caching *could* be the cause before I try that.

>  I believe that that solved the problem
> for me, although it happened rarely.  I only use `berkeley-nosync' for
> `duplicate_db' and `tlscache_db', but I suspected that the problem was
> the result of a database deadlock.

We use skiplist, which to my mind makes it even less likely that that's the 
cause ... thanks for the suggestion anyway.
     .:.Sebastian Hagedorn - RZKR-R1 (Gebäude 52), Zimmer 18.:.
Zentrum für angewandte Informatik - Universitätsweiter Service RRZK
.:.Universität zu Köln / Cologne University - ✆ +49-221-478-5587.:.
                   .:.:.:.Skype: shagedorn.:.:.:.
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 186 bytes
Desc: not available
Url : 

More information about the Info-cyrus mailing list