One more attempt: stuck processes

Gary Mills mills at
Wed Nov 14 10:30:45 EST 2007

On Wed, Nov 14, 2007 at 04:15:13PM +0100, Sebastian Hagedorn wrote:
> I've brought up this topic before. We've been running cyrus-imapd very 
> happily for several years. Yet there's one issue that none of the updates 
> have resolved. The last time I reported it we were running 2.2.12. Now 
> we're running 2.3.8, but the issues is the same: POP and IMAP processes 
> that use TLS/SSL get "stuck". My observations point towards dropped dial-up 
> connections as the cause. Here's an example:

Have you tried setting `tls_session_timeout' to zero in imapd.conf to
disable caching of TLS sessions?  I believe that that solved the problem
for me, although it happened rarely.  I only use `berkeley-nosync' for
`duplicate_db' and `tlscache_db', but I suspected that the problem was
the result of a database deadlock.

-Gary Mills-    -Unix Support-    -U of M Academic Computing and Networking-

More information about the Info-cyrus mailing list