problems with tls/ssl

Roland Felnhofer roland.felnhofer at
Fri Aug 24 15:01:34 EDT 2007

Hi Philippe,

I just rushed through the how-to and your certs and keys should be ok - 
nonetheless it still irritates me that the request file and the key are 
in one file ('newreq.pem').

I recommend to increase the debug level of cyrus (I don't know by heart 
how to do it, but it should be quite easy to find it out.)
It would help if the logs are more detailed.

I'll be out for a one week of vacation, so don't worry if I don't 
responses immediately.

Best regards

Philippe Trolliet wrote:
> hi,
> when i try to change the ssl/tls certificates i get an error in maillog with
> following message:
> Fatal error: tls_start_servertls() failed
> here my cyrus config:
> ...
> tls_cert_file: /etc/pki/cyrus-imapd/newcert.pem
> tls_key_file: /etc/pki/cyrus-imapd/newreq.pem
> tls_ca_file: /etc/pki/cyrus-imapd/cacert.pem
> ...
> i used this howto to setup my own CA:
> .html
> for the first time ssl worked just over imap. after a while my pop3s worked
> too but before i got the above error message.
> now i get the same error messages with an new certificate. both doesn´t
> work, imaps und pop3s.
> what´s going on?
> regards
> philippe
> ----
> Cyrus Home Page:
> Cyrus Wiki/FAQ:
> List Archives/Info:

-------------- next part --------------
A non-text attachment was scrubbed...
Name: smime.p7s
Type: application/x-pkcs7-signature
Size: 3673 bytes
Desc: S/MIME Cryptographic Signature
Url : 

More information about the Info-cyrus mailing list