Sieve authentification (against mysql) problem

Andreas Winkelmann ml at
Tue Sep 19 09:57:17 EDT 2006

Am Tuesday 19 September 2006 14:58 schrieb Bjoern Burger:

> i have trouble with sieve and hope someone can tell me a way out.
> Google is not my friend today.
> I have installed a Debian server with Cyrus, Sendmail and WebCyradm.
> The user authentication works against a mysql database.
> Almost every thing works fine, all usernames and passwords are stored in
> the MYSQL, i can create accounts
> with WebCyradm, can recieve mail and send mail.
> But i can´t set vacation messages anymore.
> I set them with WebCyradm.
> It works fine for a while, i have tested it a lot, because I changed
> a little bit in the Webcyradm php files.
> I got now an error "Failed to login" , when I try to set a vacation
> message. When I print the variables which used for authentication it prints
> cyrus with the correct password.
> It seems that sieve doesn´t authenticates against the mysql Database
> anymore(?). There are no entrys in the mysql.log for trying to get a
> password for the cyrus user from the mysql database.
> Using the original WebCyradm files, after getting trouble, works for 1 or 2
> tries, but now I get the same error with
> the original files.
> So i installed cyrus-clients on a remote machine und try sivtest.
> I can connect to the server, but get an "Authentication failed. generic
> failure " error after typing in my password.
> I call sivtest "sivtest -u cyrus machinename.domain.tld" und get a prompt
> that asks for the password.
> But now there are "new" messages in auth.log. And i see that cyrus/sieve
> try to get a username for root at machinename
> from the mysql database.
> Tried to solve this by adding root at machinename with a password to the
> accountuser table in the mysql database, but it doesn´t work.

-u is the Authorization-Id. -a is what you want. If you omit -a, the logged in 
User is used, in your Case root at ... .

$ sivtest -a cyrus server.domain.tld

Maybe add both:

$ sivtest -a cyrus -u cyrus server.domain.tld

Test this, and report Errors. Check the Log on the Server, too.

Here is a short description for Authorization and Authentication:


More information about the Info-cyrus mailing list