Solaris compile fails cyrus-sasl 2.1.22

Vincent Fox vbfox at
Wed Jul 26 17:17:30 EDT 2006

Ian Logan wrote:
> You might try installing OpenSSL, I'm pretty sure thats what I did 
> when I ran into the problem you described.
> I think (not sure) that cyrus-sasl will then use the MD5 digest 
> routines from OpenSSL.
> Ian

Thanks Ian, but I had OpenSSL 0.9.7j already compiled into the usual 
location. If you look at my configure line you'll see I referenced it. 
Cyrus SASL will compile for me if I disable DES support, but as it turns 
out our Kerberos setup uses DES so I do need it.

I do see that at the point where compile fails, it doesn't seem to have 
any -I/usr/local/ssl on it, but I believe I am following correct 
procedures here and just not getting the results I would expect.  I've 
tried running that cc manually adding -I for my SSL location but that 
doesn't help either.

I gather from other archived threads on this, that the multitude of 
copies of des.h found on a Solaris system are a complicating factor but 
so far have not found a good solution to untangle it.

More information about the Info-cyrus mailing list