reconstruction problems

Andrew Morgan morgan at
Fri Dec 15 13:40:18 EST 2006

On Fri, 15 Dec 2006, stas khromoy wrote:

> Hash: SHA1
> i've tried -f option as well
> and it came up with the same result
> i've monitored both /var/log/imapd.log and /var/log/messages
> for errors during reconstruction ..i did not see anything
> searched for imap_ioerror string as well in the above logs with no results.
> i found this old post
> where the guy resolved the issue by creating the error causing folder
> and running reconstruct again
> thou he is getting
> "system I/O error No such file or directory"
> i only see
> "system I/O error system I/O error"
> wish i can try it now
> instead of waiting for the end of the business day

I've ran into this problem occasionally when I goof up and delete a folder 
from the filesystem rather than using cyradm (usually when I'm trying to 
restore a folder for a user).

What I have done in the past is:

1. Create the missing folder in the filesystem by hand.
2. Copy the cyrus.header file from the user's INBOX into the folder.
3. Set the folder and cyrus.header permissions and ownership correctly for 
4. Run "su cyrus -c '/usr/local/cyrus/bin/reconstruct -f -r user.username'".
5. Run "su cyrus -c '/usr/local/cyrus/bin/quota -f user.username'".
6. Using cyradm, delete the folder.


More information about the Info-cyrus mailing list