reconstruction problems

stas khromoy stas at
Fri Dec 15 10:07:16 EST 2006

Hash: SHA1

the folders were not there to begin with
they were removed a while ago

but when i run reconstruct
they are being detected.

could the db be corrupt ?
or maybe the cyrus.header files still has them indexed some how ?

the only thing i can think off to 'fix' it
is to manually copy (via a mail client) all the emails from one mailbox
to another 'dummy' one. delete old one and copy all the emails back
but the mailbox size is outrageous (7.2GB) so doing it will take me some
serious time and i'd like to avoid it


Wesley Craig wrote:
> Just to be clear, the problem is that reconstruct inappropriately
> deleted folders after an error?  Or, reconstruct is giving errors for
> folders that were deleted (by the user) so you feel the errors are
> inappropriate?
> :wes
> On 15 Dec 2006, at 09:14, stas khromoy wrote:
>> while working on replication
>> i found that one of the mailboxes was not replicating right
>> as advised i ran recontruction -r user.username
>> i am getting
>> a bunch of these
>> user.username.2004.september: System I/O error System I/O error
>> now the folders that cause the error are no longer there.
>> reconstruction output also shows other folders that no longer exist
>> but with out the above error
>> ie. user.username.Sent.sent_2003
>> been googling around but haven't found anything of use
Version: GnuPG v1.4.5 (MingW32)
Comment: Using GnuPG with Mozilla -


More information about the Info-cyrus mailing list