Berkeley DB upgrade - 2nd try

Andrew Morgan morgan at
Mon Aug 28 16:28:01 EDT 2006

On Mon, 28 Aug 2006, Paul Boven wrote:

> Hi everyone,
> A bit over a month ago I tried to upgrade the Berkeley DB on a Cyrus-2.2.12 
> mailserver. That didn't work out because right at startup, 'ctl_cyrusdb -r' 
> would fail with 'critical dabase situation'.
> After a bit of debugging, I've gotten things down to this:
> If I build cyrus against the old version (4.1.25), it runs great. If I build 
> it against 4.4.20, it doesn't want to start. Even though I've changed 
> tlscache_db and duplicate_db to 'skiplist' in the imapd.conf and removed 
> those db-files from the system, so it shouldn't even be using Berkeley-db 
> anymore, with all databases being skiplist.
> Starting with a clean /var/imap, I can start the newly compiled Cyrus, so it 
> has to do with whatever is left in /var/imap/db from the old Berkeley 
> version.
> I've also done a db_upgrade in /var/imap using the 4.4.20 db_upgrade version, 
> but the Cyrus with the 4.4.20 Berkeley libs still won't start.
> I'd welcome any suggestions on how to proceed and make this into a working 
> mail-server again. (Don't worry, this is only the testbed - the really scary 
> stuff is yet to come).

Have you tried simply deleting any databases that use Berkeley DB (sounds 
like none in your case) and deleting all the files in the
{configdirectory}/db/ directory?  When I did a Debian upgrade from Woody 
to Sarge (OS upgrade) I had to whack that stuff to get it to come back up. 
I don't know why the Berkeley DB tools don't clean up the 
{configdirectory}/db/ directory.


More information about the Info-cyrus mailing list