Problem with timsieved on SUN

hhuseman bofh at
Thu Oct 6 17:37:29 EDT 2005

Hi Ken,

okay, one step further: sivtest is working now. The problem was that 
timsieved was unable to write into /usr/sieve, I created this directory 
and did a chown cyrus:other /usr/sieve.
Ah, and, I have the logs, I had to reconfigure my syslogd. Now sieve 
writes its messages to /var/adm/messages.
I can login now using sivtest, but, sieveshell is still not working.
I see the following entry in the log:

Oct  6 23:16:06 palanthir master[10258]: [ID 392559 local6.debug] about 
to exec /usr/cyrus/bin/timsieved
Oct  6 23:16:06 palanthir sieve[10258]: [ID 518349 local6.debug] executed
Oct  6 23:16:07 palanthir perl[10257]: [ID 702911 auth.notice] Bad 
Oct  6 23:16:07 palanthir sieve[10258]: [ID 921384 local6.debug] 
accepted connection
Oct  6 23:16:07 palanthir master[3781]: [ID 310780 local6.debug] process 
10258 exited, status 0
Oct  6 23:16:08 palanthir master[3781]: [ID 310780 local6.debug] process 
10256 exited, status 0
I found a thread which deals with the same problem:
so, I recompiled cyrus with


but with the same result.

Any ideas??

Thanks in advance,


Ken Murchison wrote:

> hhuseman wrote:
>> Hi all,
>> I've found many threads concerning this case, but nothing seems to 
>> help. So, I post it to the list, and hope that someone can help me 
>> figuring out what's going on.
>> Well, here's my problem:
>> I've just setup cyrus imapd on my SUN E250, OS is Solaris 10. Imap 
>> itself is running perfectly well, I can login to the cyradm-shell, 
>> create mailboxes, get my emails using imap, and so on.
>> The only thing which is just drivin' me nuts is timsieved. I can 
>> telnet it:
>> =======/snip/========
>> [][](22)> telnet palanthir 2000
>> Trying
>> Connected to palanthir.
>> Escape character is '^]'.
>> "IMPLEMENTATION" "Cyrus timsieved v2.2.12"
>> "SIEVE" "fileinto reject envelope vacation imapflags notify 
>> subaddress relational comparator-i;ascii-numeric regex"
>> OK
>> logout
>> OK "Logout Complete"
>> Connection to palanthir closed by foreign host.
>> cyrus(other)@palanthir:~
>> =========/snap/====================
>> okay, this works. Now, the same with sivtest:
>> =========/snip/=====================
>> sivtest -c -v -m PLAIN -u cyrus -a cyrus palanthir
>> S: "IMPLEMENTATION" "Cyrus timsieved v2.2.12"
>> S: "SASL" "PLAIN"
>> S: "SIEVE" "fileinto reject envelope vacation imapflags notify 
>> subaddress relational comparator-i;ascii-numeric regex"
>> S: OK
>> Please enter your password:
>> S: NO "Authentication Error"
>> Authentication failed. generic failure
>> Security strength factor: 0
>> Connection closed.
>> cyrus(other)@palanthir:~
>> ===========/snap/===============
>> And that's it. Unfortunately, I can't find anything in the logs, 
>> neither /var/adm/messages nor /var/log/syslog gives any clue.
>> So, I hope someone here has an idea...
> You're looking in the wrong logs.  Assuming you have things setup 
> according to the documentation, look in /var/log/imapd.log and 
> /var/log/auth.log
> What does you imapd.conf look like?
> My guess is that this problem isn't limited to timsieved.  Try 
> changing sivtest to imtest with the same arguments and see what 
> happens (you may have to add -s or -t '' in order to use PLAIN with 
> imapd).

More information about the Info-cyrus mailing list