cyradm not working after upgrade

Matt Singerman matt.singerman at
Tue Nov 29 10:45:35 EST 2005

Hmmm...  Copying over the directory didn't work, so I opted to
reinstall Cyrus from the FreeBSD ports collection.  After some minor
tweaking, this worked and everything is once again all right.  Thanks
all for your help.

On 11/29/05, Jorey Bump <list at> wrote:
> Matt Singerman wrote:
> > Hi all,
> >
> > I recently upgraded our mailserver from FreeBSD 5.2.1 to 6.0.  Most
> > items work perfectly fine after the upgrade (and thankfully, that
> > includes Cyrus itself), but cyradm no longer works:
> >
> > # cyradm --user=cyrus localhost
> > Can't locate Cyrus/IMAP/ in @INC (@INC contains:
> > /usr/local/lib/perl5/site_perl/5.8.5/mach
> > /usr/local/lib/perl5/site_perl/5.8.5 /usr/local/lib/perl5/site_perl
> > /usr/local/lib/perl5/5.8.5/BSDPAN /usr/local/lib/perl5/5.8.5/mach
> > /usr/local/lib/perl5/5.8.5 .).
> > BEGIN failed--compilation aborted.
> >
> > Now, as part of the upgrade, I installed perl 5.8 (previously, Perl
> > 5.6 had been installed), and I am assuming that this is the root of
> > the problem.  Is there a simple solution to fix this, such as
> > correcting the libraries?  I already tried copying over to
> > one of the searched directories, but that didn't work.  Alternately,
> > can I reinstall cyradm, and if so, what is the best way to go about
> > this?
> FWIW, I'm currently evaluating Cyrus IMAP on a Slackware Linux server,
> and experienced the same thing last week. Because I had multiple perl
> versions on the machine, the module was installed in the wrong place. I
> fixed this easily by copying the entire module directory to the search
> path (not just and it worked fine. Since I was tweaking config
> settings for use on a production server, I then did a complete
> reinstall, using --prefix=/usr (which was appropriate for my machine,
> but maybe not yours).
> I don't know what you're dealing with on FreeBSD, but you can probably
> just copy the files as I did. Other options include extending the path
> with the PERL5LIB environment variable (for just the user or globally),
> or installing the Cyrus::IMAP perl module again from source, making sure
> you run it with the correct version of perl or explicitly setting the
> target directory in the Makefile.
> Then again, maybe a complete reinstall of Cyrus IMAP will just work.

More information about the Info-cyrus mailing list