Compile Problem on Fedora Core 4

Alexander Dalloz ad+lists at
Sat Nov 5 18:39:19 EST 2005

Am Sa, den 05.11.2005 schrieb Peter P. Benac um 23:38:
> Greetings,
> I am getting the following error when trying to compile on Fedora Core
> gcc -c -I.. -I/usr/local/BerkeleyDB.4.3/include    -DHAVE_CONFIG_H  -g
> \
> libconfig.c
> In file included from libconfig.h:47,
>                  from libconfig.c:57:
> imapopts.h:181: error: array type has incomplete element type
> make[1]: *** [libconfig.o] Error 1
> make[1]: Leaving directory `/home/ppbenac/mail/cyrus-imapd-2.2.8/lib'

That version has security issues.

> I have tried this 2.2.10 and 2.2.12 with the same error.
> I did a web search with not joy..  Anybody solve this issue or can
point me
> in the right direction..
> Regards,
> Pete

Why at all do you try to compile from sources? Not recommended on an RPM
system like Fedora. If you really think you need to change anything
compared to the Cyrus-IMAPd Fedora ships with (Fedora Extras), then get
the src.rpm and add your patch. Or get the very nice package from Simon
Matter (pre-packager of the FE rpm):

> Peter P. Benac, CCNA


Alexander Dalloz | Enger, Germany | GPG 0xB366A773
legal statement:
Fedora Core 2 GNU/Linux on Athlon with kernel 2.6.11-1.35_FC2smp 
Serendipity 00:38:49 up 7 days, 22:39, load average: 0.17, 0.18, 0.17 
-------------- next part --------------
A non-text attachment was scrubbed...
Name: not available
Type: application/pgp-signature
Size: 189 bytes
Desc: Dies ist ein digital signierter Nachrichtenteil
Url :

More information about the Info-cyrus mailing list