cyrus-imapd appears dead

Michael Ballard baleful at
Fri Sep 3 20:07:26 EDT 2004

OK, my spin-off thread from INBOX issue

Configuration files:

System: Fedora Core 2

[root at thesewer modules]# rpm -qa | grep cyrus
[root at thesewer modules]# rpm -q sendmail
[root at thesewer modules]# rpm -q squirrelmail

My problem is simple. cyrus-imapd doesn't appear to be working. With all my config files as they are, I receive E-mail, but must use Webmin or SSH to check it. I can't get it through IMAP. Mozilla Mail reports no messages on the server. Squirrelmail reports:

ERROR : Could not complete request.
Query: CREATE "mail/Sent"
Reason Given: Invalid mailbox name"

I've used cyradm to create the mailboxes user.baleful and user.mballard and all the others, but same error all across. I've tried making user.baleful.Sent and that returns the same error in Squirrelmail.

What I originally had was Fedora Core 1 with uw-imap, and it worked. Only problem was that I couldn't figure out smtp relaying (based on authentication). From what I understood, I needed this cyrus-imapd and cyrus-sasl thinggy...which have been implemented into FC2. So I figure, hey! No problem, now it will all work right! But it never has.

When I tweak my file and include the lines that are commented out by

dnl #Added by baleful for cyrus-imapd

I get no mail at all. I can still send, but cannot receive. Then I take those lines back out, and get my E-mail again.

I don't know if I'm being very clear or not, but I hope I am, because I'm at my wits' end with this; and I start school soon, which will be grueling enough.

Thanks for your help!

More information about the Info-cyrus mailing list