Virtual Domains Stopped working

Peter P. Benac ppbenac at
Wed Sep 29 14:00:36 EDT 2004


    I updated my DNSBL support in sendmail the other day and my virtual
domains stopped working.  

    Sendmail through the lmtpd socket delivers the mail to
/var/spool/imap/user/{whateveruser}.  IMAPD and POP3D are looking for the
mail in /var/spool/imap/domain/{whateverdomain}/user/{whateveruser}.  This
never happened before I updated my file.

Here are the appropriate lines in my file (version Sendmail

define(`confLOCAL_MAILER', `cyrusv2')dnl

Here is my imapd.conf file: (Cyrus version 2.2.3)

sasl_mech_list:  {removed on purpose}
sasl_pwcheck_method: {removed on purpose}
sasl_auxprop_plugin: sasldb
sasl_sasldb_path: /etc/sasldb2
configdirectory: /var/imap
partition-default: /var/spool/imap
lmtpsocket: /var/imap/socket/lmtp
sievedir: /var/imap/sieve
admins: cyrus
virtdomains: userid

System is running Solaris 8.  As I stated this all worked until I rebuilt my file by adding a few DNSBL's.  I tried removing the new DNSBL's
and still had the problem.

Any clue where to look would be helpful.


Peter P. Benac, CCNA
Emacolet Networking Services, Inc
Providing Systems and Network Consulting, Training, Web Hosting Services
Phone: 919-847-1740 or 866-701-2345
Need quick reliable Systems or Network Management advice visit

To have principles...
             First have courage.. With principles comes integrity!!!

Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list