newbie authentication problem

Peter Duda pduda at
Wed May 26 17:56:35 EDT 2004

I am new to this whole cyrus thing, but I am trying to learn.  

RedHat 9.0
Cyrus 2.2.3-8
Cyrus SASL 2.1.18
Mysql 3.23.58

I sort of had everything working so far by myself and a lot of Googleing
:).  But now I am having a difficult time getting the authentication to
work properly.  Web-cyradm works fine and sees all the cyrus info in the
mysql database, but I cannot connect to cyrus through other means:
imtest gives

S: L01 NO Login failed: user not found
Authentication failed. generic failure
Security strength factor: 0
Connection closed.

use not found shows up when I try and connect through evolution or OGo,

I know the user is there because I can see them in web-cyradm

I have tried multiple imapd.conf files including the HOWTO with
pam_mysql etc, but that didn't work.

/var/log/messages gives a lot of these

Flashy pop3[11789]: sql_select option missing
Flashy pop3s[11790]: auxpropfunc error no mechanism available

I have tried auth with auxprop but it's not working either:
this was the imapd.conf file

configdirectory: /var/lib/imap
partition-default: /var/spool/imap
admins: cyrus root
allowplaintext: yes
sievedir: /var/lib/imap/sieve
sendmail: /usr/sbin/sendmail
hashimapspool: true
tls_cert_file: /usr/share/ssl/certs/cyrus-imapd.pem
tls_key_file: /usr/share/ssl/certs/cyrus-imapd.pem
tls_ca_file: /usr/share/ssl/certs/
pwcheck_method: auxprop
auxprop_plugin: sql
sql_engine: mysql
mech_list: login plain
sql_hostnames: localhost
sql_user: user
sql_passwd: password
sql_database: mail
sql_verbose: yes
sql_select: SELECT password FROM accountuser WHERE username = '%u@%r'

/var/log/messages gives more of these:

pop3[11465]: sql_select option missing
pop3[11465]: auxpropfunc error no mechanism available
pop3[11465]: unable to open Berkeley db /etc/sasldb2: Permission denied

the closest i came was when my imapd.conf looked like this:

configdirectory: /var/lib/imap
partition-default: /var/spool/imap
admins: cyrus root
allowplaintext: yes
sievedir: /var/lib/imap/sieve
sendmail: /usr/sbin/sendmail
hashimapspool: true
pwcheck_method: saslauthd
sasl_mech_list: PLAIN
sasl_sql_engine: mysql
sasl_sql_hostnames: localhost
sasl_sql_user: user
sasl_sql_passwd: password
sasl_database: mail
sasl_sql_select: select password from accountuser where username = '%u'
tls_cert_file: /usr/share/ssl/certs/cyrus-imapd.pem
tls_key_file: /usr/share/ssl/certs/cyrus-imapd.pem
tls_ca_file: /usr/share/ssl/certs/

/var/log/messages doesnt give any errors upon startup, but when you try
and login then:

Flashy imap[11940]: sql plugin could not connect to host localhost
Flashy imap[11940]: sql plugin couldn't connect to any host
Flashy imap[11940]: unable to open Berkeley db /etc/sasldb2: Permission

Now I used to just get the plugin error and not the Berkeley db error
and when that was happening I could login under the admins, but it
wouldn't work with a user - it still wasn't querying the mysql
database.  But with all the changes now I can't open the Berkeley db
which put me a step backwards.

Can someone point me in the right direction?  I am really new to all of
this so forgive my rambling, but I would like to get this working


Cyrus Home Page:
Cyrus Wiki/FAQ:
List Archives/Info:

More information about the Info-cyrus mailing list