?? Need some help!

Drewe Zanki drewe at arntech.com.au
Thu Jan 29 17:32:46 EST 2004

I have no idea what is going on here - I am trying to install Cyrus and SASL,
but have a problem at ./configure - here is what I get -

[root at server cyrus-sasl-2.1.17]# ./configure
: bad interpreter: No such file or directory

So I uncommented the first line (! /bin/sh) and ran it again -

[root at server cyrus-sasl-2.1.17]# ./configure
: No such file or directoryh
: command not found2:
./configure: line 20: syntax error near unexpected token `elif'
'/configure: line 20: `elif test -n "${BASH_VERSION+set}" && (set -o posix)
>/dev/null 2>&1; then

As it turns out, Line 20 is the first line of code.... I have also tried
/bin/bash with no success.

I am running Fedora Core 1, almost a full install. I get this error on both
Cyrus and SASL, so there must be something I am doing. I even went for the
crazy stuff - did a CHMOD 777 on the configure file, tried 'sh ./configure',
tried changing the owners, etc (I know none of these should work, but tried in

Can someone point me in the right direction - or tell me where I am going
wrong? I have had no problems in the past compiling anything, so I guess this
is a first :-). The PC is a Pentium II-266 with 320 Meg RAM - Fedora Core 1
running in console mode only (I use SSH to get to it), plenty of disk and
running sendmail.

I am currently using Dovecot (thats what came with the distro), but it's bugs
are way too much for me!

Thanks in advance


More information about the Info-cyrus mailing list