checking for db_create in RH9

Simon Matter simon.matter at
Fri Feb 6 06:07:26 EST 2004

> Simon Matter wrote:
>>>So I tried to install from source. I read redhat db4 was
>>>buggy so I built a new one with the db4.spec file from
>> That's my site. Rebuilding cyrus-imapd is always possible even with the
>> original db4 packages. The only problem is that they make problems on
>> certain cpu types.
>> Okay, but what is installed on your box right now? Something is
>> unfortunately broken. Check with 'rpm -qa | grep ^db' please.
> Right now it's:
> db4-4.0.14-20
> db4-utils-4.0.14-20
> db4-devel-4.0.14-20

Do you also have db3 packages installed? This can confuse the build
process. The rpms are made to build on stock RedHat x distributions. I
don't know what causes your problems, sorry.


> But I should point the same error happened with the nonptl
> version.
> I just tried to download db4.2 from sleepycat web and I
> installed it in /usr/local/BerkeleyDB4.2. Then I tried
> to configure cyrus-imapd again:
> # ./configure --with-bdb-libdir=/usr/local/BerkeleyDB.4.2/
> --with-bdb-incdir=/usr/local/BerkeleyDB.4.2/
> with the same results:
> checking for db.h... yes
> checking for db_create in -ldb-4.2... no
> checking for db_create in -ldb4.2... no
> ..
> checking for db_create in -ldb... no
> checking for db_open in -ldb... no
> So it looks like there is really something wrong here.
> I just made sure again I have the latest patches with:
> yum update.
> What else can I try ?
> ---
> Home Page:
> Wiki/FAQ:
> List Archives/Info:

Home Page:
List Archives/Info:

More information about the Info-cyrus mailing list