checking for db_create in RH9

Edward Rudd eddie at
Fri Feb 6 16:55:48 EST 2004

Did you try Upgrading the RPMS to the nonptl ones?
rpm -Uvh db4-*
the list of db4's should be 

if you installed the RPMS built from simon's updated spec file for RH 9.

also make sure you don't have any other db -devel packages
running 'rpm -qa db\*-devel' should only list the db4 devel packages.
if there are others try removing them (ie. rpm -e db3-devel)

Forcing installation OVER another package is always bad.. Always do an
upgrade (-U) or a freshen (-F), never use (--force)

Try looking at the config.log file in the cyrus-imapd source directory
(where the configure script is) and see what the error message it has
when it checks for db_create. then post that to the mailing list..

On Fri, 2004-02-06 at 05:39, Francesc Guasch Ortiz wrote:
> Simon Matter wrote:
> >>Simon Matter wrote:
> >>
> >>
> >>>>So I tried to install from source. I read redhat db4 was
> >>>>buggy so I built a new one with the db4.spec file from
> > Do you also have db3 packages installed? This can confuse the build
> > process. The rpms are made to build on stock RedHat x distributions. I
> > don't know what causes your problems, sorry.
> Well, I have gdbm-1.8.0-20, but I think it's ok.
> Thank you for trying. I wanted to keep the rpms, but
> now I tried to build from tar.gz and it won't work either.
> Someone has any clue ?
> Summary: I can't configure cyrus-imapd-2.1.16 in a RH 9.
> I tried db4 from redhat, db4 nonptl and db4.2 installed
> from source in /usr/local/BerkeleyDB4.2.
> I always get:
> checking for db.h... yes
> checking for db_create in -ldb-4.2... no
> ...
> checking for db_create in -ldb3... no
> checking for db_create in -ldb... no
> checking for db_open in -ldb... no
> configure: error: this version requires Berkeley DB 3.x or later.
> ---
> Home Page:
> Wiki/FAQ:
> List Archives/Info:
Edward Rudd <eddie at>

Home Page:
List Archives/Info:

More information about the Info-cyrus mailing list