mupdate and SASL

Jim Levie jim at
Fri Feb 20 17:32:08 EST 2004

On Wed, 2004-02-18 at 13:47, Prentice Bisbal wrote:
> I'm having problems trying to authenticate to mupdate using sasl. I've 
> been trying to authenticate using mupdatetest, but keep getting the 
> following error:
> Feb 18 14:33:48 pdb-mail-1 mupdate[21606]: Password verification failed
> Feb 18 14:33:51 pdb-mail-1 mupdate[21606]: badlogin: 
> localhost.localdomain [] PLAIN SASL(-13): user not found: 
> Password verification failed
> My mupdate username is mupdate, my domain/realm is 
> I've tried mupdatetest w/all of the following
> mupdatetest -u mupdate -a mupdate -r
> mupdatetest -u mupdate -r
> mupdatetest -u mupdate at
> My salsdb entry for this user is
> mupdate at userPassword
I haven't looked at the code to see why, but I've just tried specifying
an invalid realm, e.g.:

mupdatetest -p 3905 -u dunno -a dunno -r dufus.tld mupdate.srv.tld

and it worked just as if I had not specified a realm. So it looks to me
like the realm isn't being used at all. On my mupdate server I found
that the mupdate user needed to be in sasldb like:

dunno at mupdate.srv.tld: userPassword

with the realm being the hostname of the mupdate server for it to work.
I haven't tested, but I suspect that if you set "servername" in
imapd.conf on the mupdate server you'd need that realm when creating the
sasldb account for the mupdate user.

The instructions said to use Windows 98 or better, so I installed RedHat
   Jim Levie                                 email:jim at

Home Page:
List Archives/Info:

More information about the Info-cyrus mailing list