Sendmail error: Deferred: Bad file descriptor when delivering some messages

Andrzej Filip anfi at
Wed Nov 12 11:10:00 EST 2003

Oscar Olsson wrote:
> Hi!
> I've noticed a quite annoying problem with my cyrus setup. Some messages
> get delivered, but sendmail sees it as a delivery failure, and sends a
> 4XX error to the sending SMTP server/client. This makes the sending
> server/client retry the send, which ofcourse produces the same error
> again, and then another copy of the message appears in the users
> mailbox. This happens again and again until the users mailbox gets over
> quota.
> I'd like to know what's causing this. It seems like its only some
> messages that produce this error. Other messages get delivered just fine
> with no error. (!?) Full headers of these "failed" messages can be
> obtained upon request. Yes, I have tried running "reconstruct -r" on the
> mailbox.
> Environment: Linux slackware
> Sendmail 8.12.1 - compiled from source on the local cyrus server
> Cyrus 2.0.17 - compiled from source on the local cyrus server
> Sendmail and cyrus have been compiled with SASL support and sendmail
> also has SMTP AUTH support compiled in, however I doubt that this has
> anything to do with the problem.
>>From the maillog:
> Nov 12 14:31:09 e2home-imap sendmail[846]: hAABDDkt012554:
> to=<someuser at>, delay=2+02:17:56, xdelay=00:00:00,
> mailer=cyrus, pri=18213656, relay=localhost [[UNIX:
> /var/imap/socket/lmtp]], dsn=4.4.2, stat=Deferred: Bad file descriptor
> If I forward the same message, it gets delivered without any problems.
> imapd.log doesn't have any clues either.
> Does anyone recognize this error? Is it an lmtp bug och a sendmail
> bug/malfunction? Any clues on what may be causing this? I appreciate all
> feedback I can get right now. :/

What is reported when you push the queuened message in verbose mode ?
As root run:
sendmail -v -qIhAABDDkt012554

Andrzej [pl>en: Andrew] Adam Filip
anfi at anfi at [former: anfi at]

More information about the Info-cyrus mailing list