Cyrus IMAP 2.1.12 and Berkeley 4.1.25

Christian Schulte cs at
Fri May 2 11:21:10 EDT 2003

Joe Rhodes wrote:

> Hello all:
> My apologies for what seems to me to be kind of a dumb question, but I 
> just can't seem to get around this.
> I can't seem to get past the ./configure with Cyrus IMAP.  It always 
> complains when it's looking for db_create in the Berkeley db.h file.
> I've uninstalled the db4 rpms that RedHat 9 ships with (db4, 
> db4-devel, and db4-util) and compiled my own version of Berkeley DB 
> 4.1.25, using --prefix=/usr as the only compile option.  I had no 
> errors in the build process.   I need to use 4.1.25, since OpenLDAP 
> requires it.  (OpenLDAP, BTW, compiles and links fine against the 
> library.)  I'd prefer to use this version also for Cyrus IMAP and SASL 
> if I can.  (Havn't gotten around to the latter yet).  From what I've 
> read, Cyrus IMAP and SASL can use the Berkeley 4.1.25 library.
Yes! You can link both against db-4 !

> The configure script finds the db.h file, and then proceeds to check 
> for db_create in db-4.1, db4.1 and so on.  It doesn't find it and then 
> gives the message that I should install Berkeley DB from 

Where do you have files ? Does your linker search that 
path during linking ? It seems that cannot be found ! Do 
you have ? If not: Make a link from to!

> I've tried putting Berkeley DB in its own directory, 
> /usr/local/Berkeley and use the --with-dbdir --with-db-libdir and 
> --with-db-incdir to point there, that didn't work.  I've tried using 
> those same ./configure flags to point at my /usr/lib and /usr/include 
> directories.  No dice.

So you only have and not I think !


More information about the Info-cyrus mailing list