Cyrus IMAPd 2.1.13 Released

Bob Tito lists at
Sat May 3 04:35:27 EDT 2003

Ken Murchison said:
> Bob Tito wrote:
>> Ken Murchison said:
>> Hi Ken,
>>>Sounds to me like either you had a hacked version of 2.1.12 or you
>>>enabled and then disabled unixhierarchysep.  By default, Cyrus doesn't
>>>allow '.' in the usernames, so /usr/sieve/?/ should never
>> I am sorry to dissapoint you, but NO hack applied, and from the start i
>> had unixhierarchysep: yes in my imapd.conf , and at some moment i added
>> altnamespace: yes.. that is all. All the time the sieve scripts remained
>> working until the upgrade to 2.1.13.
>> Again, perhaps i am to blame, who knows... ;-)
>> But, it seemed important enough to give notice about that. Solved here
>> in
>> 5 minutes, but others might have bigger impact ?
> I stand corrected.  I just looked at the CVS logs and this change was
> made between 2.1.12 and 2.1.13.  The old behavior was inconsistent with
> the rest of the code, and the change fixed this.  Apparently none of us
> gave any thought to th efact that this would break existing
> installations  :(
> As you noted, this is easily fixed with a perl/shell script run on the
> sievedir.

Ok this is solved then ;-)
But could this change also have broken squatter ?
i tried to use this (just finding out all possibilties) and is look like
it cannot handle the maildirs in this format ?

Regards, Bob

> --
> Kenneth Murchison     Oceana Matrix Ltd.
> Software Engineer     21 Princeton Place
> 716-662-8973 x26      Orchard Park, NY 14127
> --PGP Public Key--

This account is only used for mailinglistst
Please use bob at magicfingers dot org if you want to contact me.

Bob Tito

More information about the Info-cyrus mailing list