pwcheck doesn't work after system restart

Stewart stewart at
Wed May 21 21:25:24 EDT 2003


system: debian 3.0 woody PPC
cyrus imapd v1.5.19 (installed with apt, not compiled)

I'm trying cyrus for the first time this week, and having fun riding 
the learning curve. :) All going OK so far except last night i switched 
the machine off and after starting up again this morning i can't 
connect due to 'cannot connect to pwcheck server' , as it says in the 

I can't for the life of me work out why. there is no indication of any 
errors, apart from 'can't connect' in any of the logs. i've tried 
/etc/init.d/pwcheck start but there is no pwcheck showing up in the 
process list. have tried restarting xinetd. have tried removing the 
/var/state/pwcheck files (this is like a pid or lockfile, no?)

but all to no avail. i'm running out of ideas. am i right in presuming 
that as pwcheck is a daemon it ought to show up in the ps list if it's 
running? or does it only run when actually being used?

i'm also a tad confused because the docs say cyrus uses sasl auth by 
default but my system (up until this morning) was clearly using local 
UNIX user auth - ie /etc/passwd.

any suggestions gratefully received...


More information about the Info-cyrus mailing list