Can't delete old folders from before ALTNAMESPACE

Lee lee_hoffman at
Mon Jun 16 15:31:55 EDT 2003

I created the directories spool/imap/user/joe/INBOX and INBOX/A =D and 
INBOX/A =D/Accounts, then i ran recontruct -R on user/joe, but that 
just returned the following errors:

user.joe.INBOX.A =D: System I/O error Bad file descriptor
user.joe.INBOX.A =D.Accounts: System I/O error Bad file descriptor

This is odd since we're using the / as the directory seperator not "." 
(which we used to use a long time ago).

BTW i also tried creating and reconstructing two top level directory 
folders spool/imap/user.joe.INBOX.A =D and spool/imap/user.joe.INBOX.A 
=D .Accounts, but it didn't change the error I recieved when running 

Any other ideas?


On Monday, June 16, 2003, at 03:16 PM, Rob Siemborski wrote:

> On Mon, 16 Jun 2003, Lee wrote:
>>> You should be able to delete these from within cyradm as an admin,
>>> unless
>>> somebody deleted stuff by hand from the filesystem.
>> I think that might be the problem.
> Don't do that! ;)
> To fix the problem, recreate the directories in the filesystem,
> reconstruct the mailboxes, and then delete them properly via cyradm.
>> Is there a way to force remove cyrus' internal list of those folders?
> Not any easy ways, there are some test utilities for cyrusdb 
> functionality
> that let you manipluate the database on a per-key basis.  They're in 
> the
> distribution, but they're a use-at-your-own-risk sort of thing.
> -Rob
> -=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-=-
> Rob Siemborski * Andrew Systems Group * Cyert Hall 207 * 412-268-7456
> Research Systems Programmer * /usr/contributed Gatekeeper

More information about the Info-cyrus mailing list