Problem rebuilding deleted mailbox directories with reconstruct from 2.1.15

Michael Sims michaels at
Thu Aug 28 13:07:01 EDT 2003


I recently upgraded from Cyrus IMAP 2.1.14 to 2.1.15, and I'm having
problems with the changes made to the reconstruct utility between those
versions that I was hoping someone here could help me with.  I apologize if
this has been discussed before, or if I'm missing something obvious in the

On my server I have a need to frequently run reconstruct on a mailbox when
the actual filesystem directory has been deleted.  (Don't ask - it's a long
story and not particularly interesting.)  For example, let's suppose I have
a mailbox named "user/foo" and "user/foo/test", and I have the following


Suppose that "/var/spool/imap/f/user/foo/test" was removed.  With previous
versions of Cyrus IMAP I could repair this mailbox by simply recreating the
directory with the proper ownership and permissions, and then running
"reconstruct user/foo/test".  Reconstruct would rebuild the
cyrus.(cache|header|index) files and everything would be peachy.

The version of reconstruct that comes with 2.1.15 gives me the following
error when I try to do the above: Mailbox has an invalid format

For kicks (since this particular mailbox was hosed anyway) I tried the
reconstruct binary from 2.1.14 and it worked.

Is the new version of reconstruct not able to rebuild the cyrus metadata
files?  Or am I missing something obvious?  Any assistance would be very
much appreciated...

Michael Sims
Project Analyst - Information Technology
Crye-Leike Realtors
Office: (901)758-5648  Pager: (901)769-3722

More information about the Info-cyrus mailing list