cyrus authentication...

Kevin Williams kewilliams at
Thu Apr 10 20:02:45 EDT 2003


I'm hoping someone can help me with this error.  I can successfully test
the cyrus installation.  When I try to login using cyradm I get the
following error:

/usr/local/bin/cyradm -u cyrus --auth plain localhost
Login failed: user not found at
/usr/lib/perl5/site_perl/5.8.0/i386-linux-thread-multi/Cyrus/IMAP/ line 114
cyradm: cannot authenticate to server with plain as login

and in my imap log:
Apr 10 16:48:02 www imapd[21965]: accepted connection
Apr 10 16:48:02 www imapd[21965]: badlogin: web01[] PLAIN
[SASL(-4): no mechanism available: security flags do not match required]
Apr 10 16:48:05 www imapd[21965]: badlogin: web01[] plaintext
login SASL(-13): user not found: checkpass failed
Apr 10 16:49:08 www master[21881]: process 21965 exited, status 0

I tried setting the --auth method to plain, pwcheck, and login.  None of
them  worked.  I double checked to make sure the sasldb2 database is
owned by cyrus and cyrus has read privileges to it.  Also, my
sasl_pwcheck_method is set to auxprop.

More information about the Info-cyrus mailing list